re = /(?:spirit_animals\s*=\s*\{|(?!^)\G)\s*'\K([^']+)('\s*:\s*'[^']+',?)/
str = 'var cool_spirit_animals = {
\'Abel\': \'unicorn\',
\'Bob\': \'lion\'
};
var spirit_plants = {
\'Cain\': \'venus fly trap\'
};
var stupid_spirit_animals = {
\'Dan\': \'lamprey\'
};
var spirit_vampires = {
\'Emily\': \'Buffy\',
\'Fred\': \'Dracula\'
};'
subst = '$1 Smith$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result