#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([A-Za-z]+[\d@]+[\w@]*|[\d@]+[A-Za-z]+[\w@]*)"
Local $sString = "Should match:" & @CRLF & _
"" & @CRLF & _
"h1DF346" & @CRLF & _
"123FE453" & @CRLF & _
"3f3g6hj7j5v3" & @CRLF & _
"hasdf@asdf" & @CRLF & _
"r3" & @CRLF & _
"r@" & @CRLF & _
"Should not match:" & @CRLF & _
"" & @CRLF & _
"555555" & @CRLF & _
"@" & @CRLF & _
"hello" & @CRLF & _
"onlyletters"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")