using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Za-z]+[\d@]+[\w@]*|[\d@]+[A-Za-z]+[\w@]*)";
string input = @"Should match:
h1DF346
123FE453
3f3g6hj7j5v3
hasdf@asdf
r3
r@
Should not match:
555555
@
hello
onlyletters";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}