import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Za-z]+[\\d@]+[\\w@]*|[\\d@]+[A-Za-z]+[\\w@]*)";
final String string = "Should match:\n\n"
+ "h1DF346\n"
+ "123FE453\n"
+ "3f3g6hj7j5v3\n"
+ "hasdf@asdf\n"
+ "r3\n"
+ "r@\n"
+ "Should not match:\n\n"
+ "555555\n"
+ "@\n"
+ "hello\n"
+ "onlyletters";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}