re = /([A-Za-z]+[\d@]+[\w@]*|[\d@]+[A-Za-z]+[\w@]*)/
str = 'Should match:
h1DF346
123FE453
3f3g6hj7j5v3
hasdf@asdf
r3
r@
Should not match:
555555
@
hello
onlyletters'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end