package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-Za-z]+[\d@]+[\w@]*|[\d@]+[A-Za-z]+[\w@]*)`)
var str = `Should match:
h1DF346
123FE453
3f3g6hj7j5v3
hasdf@asdf
r3
r@
Should not match:
555555
@
hello
onlyletters`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}