using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:q'\[.*?\](?=')'|q'<.*?>(?=')'|q'\(.*?\)(?=')'|q'{.*?}(?=')'|(?!q)'(?:[^']|'')*')";
string input = @"q'[Here's Johnny]' + 't''e''s''t]'
q'<Here's Johnny>'
q'(Here's Johnny)'.anotherTest('h'')''ere')
q'{Here's Johnny}'
'Here''s Johnny'
q'[Here's J>'}'''ohnny]'
q'<Here's John'']'}'ny>'
q'(Here's Johnny)'
q'{Here's Johnny}'
'Here''s Johnny'
DECLARE
VARCHAR2(1024);
v_cnt PLS_INTEGER;
BEGIN
v_sql := q'[SELECT COUNT(*) FROM user_objects WHERE object_type = 'TABLE']';
EXECUTE IMMEDIATE v_sql INTO v_cnt;
DBMS_OUTPUT.PUT_LINE(
TO_CHAR(v_cnt) || ' tables in USER_OBJECTS.'
);
END;
/
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}