import Foundation
let pattern = #"(?:q'\[.*?\](?=')'|q'<.*?>(?=')'|q'\(.*?\)(?=')'|q'{.*?}(?=')'|(?!q)'(?:[^']|'')*')"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
q'[Here's Johnny]' + 't''e''s''t]'
q'<Here's Johnny>'
q'(Here's Johnny)'.anotherTest('h'')''ere')
q'{Here's Johnny}'
'Here''s Johnny'
q'[Here's J>'}'''ohnny]'
q'<Here's John'']'}'ny>'
q'(Here's Johnny)'
q'{Here's Johnny}'
'Here''s Johnny'
DECLARE
VARCHAR2(1024);
v_cnt PLS_INTEGER;
BEGIN
v_sql := q'[SELECT COUNT(*) FROM user_objects WHERE object_type = 'TABLE']';
EXECUTE IMMEDIATE v_sql INTO v_cnt;
DBMS_OUTPUT.PUT_LINE(
TO_CHAR(v_cnt) || ' tables in USER_OBJECTS.'
);
END;
/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)