use strict;
my $str = 'q\'[Here\'s Johnny]\' + \'t\'\'e\'\'s\'\'t]\'
q\'<Here\'s Johnny>\'
q\'(Here\'s Johnny)\'.anotherTest(\'h\'\')\'\'ere\')
q\'{Here\'s Johnny}\'
\'Here\'\'s Johnny\'
q\'[Here\'s J>\'}\'\'\'ohnny]\'
q\'<Here\'s John\'\']\'}\'ny>\'
q\'(Here\'s Johnny)\'
q\'{Here\'s Johnny}\'
\'Here\'\'s Johnny\'
DECLARE
VARCHAR2(1024);
v_cnt PLS_INTEGER;
BEGIN
v_sql := q\'[SELECT COUNT(*) FROM user_objects WHERE object_type = \'TABLE\']\';
EXECUTE IMMEDIATE v_sql INTO v_cnt;
DBMS_OUTPUT.PUT_LINE(
TO_CHAR(v_cnt) || \' tables in USER_OBJECTS.\'
);
END;
/
';
my $regex = qr/(?:q'\[.*?\](?=')'|q'<.*?>(?=')'|q'\(.*?\)(?=')'|q'{.*?}(?=')'|(?!q)'(?:[^']|'')*')/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}