const regex = /(?:q'\[.*?\](?=')'|q'<.*?>(?=')'|q'\(.*?\)(?=')'|q'{.*?}(?=')'|(?!q)'(?:[^']|'')*')/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:q\'\\[.*?\\](?=\')\'|q\'<.*?>(?=\')\'|q\'\\(.*?\\)(?=\')\'|q\'{.*?}(?=\')\'|(?!q)\'(?:[^\']|\'\')*\')', 'g')
const str = `q'[Here's Johnny]' + 't''e''s''t]'
q'<Here's Johnny>'
q'(Here's Johnny)'.anotherTest('h'')''ere')
q'{Here's Johnny}'
'Here''s Johnny'
q'[Here's J>'}'''ohnny]'
q'<Here's John'']'}'ny>'
q'(Here's Johnny)'
q'{Here's Johnny}'
'Here''s Johnny'
DECLARE
VARCHAR2(1024);
v_cnt PLS_INTEGER;
BEGIN
v_sql := q'[SELECT COUNT(*) FROM user_objects WHERE object_type = 'TABLE']';
EXECUTE IMMEDIATE v_sql INTO v_cnt;
DBMS_OUTPUT.PUT_LINE(
TO_CHAR(v_cnt) || ' tables in USER_OBJECTS.'
);
END;
/
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}