$re = '/(?:q\'\[.*?\](?=\')\'|q\'<.*?>(?=\')\'|q\'\(.*?\)(?=\')\'|q\'{.*?}(?=\')\'|(?!q)\'(?:[^\']|\'\')*\')/';
$str = 'q\'[Here\'s Johnny]\' + \'t\'\'e\'\'s\'\'t]\'
q\'<Here\'s Johnny>\'
q\'(Here\'s Johnny)\'.anotherTest(\'h\'\')\'\'ere\')
q\'{Here\'s Johnny}\'
\'Here\'\'s Johnny\'
q\'[Here\'s J>\'}\'\'\'ohnny]\'
q\'<Here\'s John\'\']\'}\'ny>\'
q\'(Here\'s Johnny)\'
q\'{Here\'s Johnny}\'
\'Here\'\'s Johnny\'
DECLARE
VARCHAR2(1024);
v_cnt PLS_INTEGER;
BEGIN
v_sql := q\'[SELECT COUNT(*) FROM user_objects WHERE object_type = \'TABLE\']\';
EXECUTE IMMEDIATE v_sql INTO v_cnt;
DBMS_OUTPUT.PUT_LINE(
TO_CHAR(v_cnt) || \' tables in USER_OBJECTS.\'
);
END;
/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);