import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bWORD\\s*((?:(?!WORD)(?:.|\\n))*?)\\s*BORDERWORD\\b";
final String string = "randomtext WORD rand\n"
+ "omtext WORD needed\n"
+ "text BORDERWORD random\n"
+ "text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}