const regex = /\bWORD\s*((?:(?!WORD)(?:.|\n))*?)\s*BORDERWORD\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bWORD\\s*((?:(?!WORD)(?:.|\\n))*?)\\s*BORDERWORD\\b', 'gm')
const str = `randomtext WORD rand
omtext WORD needed
text BORDERWORD random
text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}