$re = '/\bWORD\s*((?:(?!WORD)(?:.|\n))*?)\s*BORDERWORD\b/m';
$str = 'randomtext WORD rand
omtext WORD needed
text BORDERWORD random
text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);