re = /\bWORD\s*((?:(?!WORD)(?:.|\n))*?)\s*BORDERWORD\b/m
str = 'randomtext WORD rand
omtext WORD needed
text BORDERWORD random
text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end