import Foundation
let pattern = #"^"(\\u{1}\w+)+"$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""\u0985\u0982\u0995\u09bf\u09a4""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}