const regex = /@media.*?(\{([^{}]|(?1))*\})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@media.*?(\\{([^{}]|(?1))*\\})', '')
const str = `@media screen and (min-width:750px){h1{font-size:2.5em}}
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}