re = /@media.*?(\{([^{}]|(?1))*\})/
str = '@media screen and (min-width:750px){h1{font-size:2.5em}}
}
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end