#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d+\.\d{2}$"
Local $sString = "234234.00" & @CRLF & _
"2342342.12" & @CRLF & _
"234.11" & @CRLF & _
"2.22" & @CRLF & _
"3.33" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"3242.1" & @CRLF & _
"2342" & @CRLF & _
"3.122" & @CRLF & _
".22"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")