package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+\.\d{2}$`)
var str = `234234.00
2342342.12
234.11
2.22
3.33
3242.1
2342
3.122
.22`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}