re = /\d+\.\d{2}$/m
str = '234234.00
2342342.12
234.11
2.22
3.33
3242.1
2342
3.122
.22'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end