$re = '/\d+\.\d{2}$/m';
$str = '234234.00
2342342.12
234.11
2.22
3.33
3242.1
2342
3.122
.22';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);