import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+\\.\\d{2}$";
final String string = "234234.00\n"
+ "2342342.12\n"
+ "234.11\n"
+ "2.22\n"
+ "3.33\n\n\n"
+ "3242.1\n"
+ "2342\n"
+ "3.122\n"
+ ".22";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}