package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{4})-(\d{2})-(\d{2})T(\d{2}:\d{2}:\d{2})\.\d+Z$`)
var str = `2020-03-02T13:40:03.000Z`
var substitution = "$3-$2-$1 $4"
fmt.Println(re.ReplaceAllString(str, substitution))
}