import Foundation
let pattern = #"^(\d{4})-(\d{2})-(\d{2})T(\d{2}:\d{2}:\d{2})\.\d+Z$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"2020-03-02T13:40:03.000Z"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$3-$2-$1 $4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)