use strict;
my $str = '2020-03-02T13:40:03.000Z';
my $regex = qr/^(\d{4})-(\d{2})-(\d{2})T(\d{2}:\d{2}:\d{2})\.\d+Z$/mp;
my $subst = '$3-$2-$1 $4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";