re = /^(\d{4})-(\d{2})-(\d{2})T(\d{2}:\d{2}:\d{2})\.\d+Z$/m
str = '2020-03-02T13:40:03.000Z'
subst = '$3-$2-$1 $4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result