#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?:\d\.?)+(?:\-?\w+(?!\w))?)"
Local $sString = "<meta name="generator" content="WordPress 4.3.3" />" & @CRLF & _
"http://wordpress.org/?v=4.3.3-label" & @CRLF & _
"" & @CRLF & _
"v3.2.0" & @CRLF & _
"" & @CRLF & _
"V0.0.1beta" & @CRLF & _
"3.0.2a" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")