const regex = new RegExp('((?:\\d\\.?)+(?:\\-?\\w+(?!\\w))?)', 'g')
const str = `<meta name="generator" content="WordPress 4.3.3" />
http://wordpress.org/?v=4.3.3-label
v3.2.0
V0.0.1beta
3.0.2a
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}