import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:\\d\\.?)+(?:\\-?\\w+(?!\\w))?)";
final String string = "<meta name=\"generator\" content=\"WordPress 4.3.3\" />\n"
+ "http://wordpress.org/?v=4.3.3-label\n\n"
+ "v3.2.0\n\n"
+ "V0.0.1beta\n"
+ "3.0.2a\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}