import Foundation
let pattern = #"((?:\d\.?)+(?:\-?\w+(?!\w))?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<meta name="generator" content="WordPress 4.3.3" />
http://wordpress.org/?v=4.3.3-label
v3.2.0
V0.0.1beta
3.0.2a
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)