using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\d\.?)+(?:\-?\w+(?!\w))?)";
string input = @"<meta name=""generator"" content=""WordPress 4.3.3"" />
http://wordpress.org/?v=4.3.3-label
v3.2.0
V0.0.1beta
3.0.2a
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}