import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?: 0(?=1|\\b)| 1(?=2|\\b)| 2(?=3|\\b)| 3(?=4|\\b)| 4(?=5|\\b)| 5(?=6|\\b)| 6(?=7|\\b)| 7(?=8|\\b)| 8(?=9|\\b)| 9\\b ){5}";
final String string = "123 321 56789 890123 321098 134 333 421 12345 6789 \n"
+ "15246\n"
+ "1234567890\n"
+ "67890\n"
+ "12345\n"
+ "23456\n"
+ "34567\n"
+ "456789\n"
+ "56789\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}