import Foundation
let pattern = #"(?: 0(?=1|\b)| 1(?=2|\b)| 2(?=3|\b)| 3(?=4|\b)| 4(?=5|\b)| 5(?=6|\b)| 6(?=7|\b)| 7(?=8|\b)| 8(?=9|\b)| 9\b ){5}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"""
123 321 56789 890123 321098 134 333 421 12345 6789
15246
1234567890
67890
12345
23456
34567
456789
56789
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)