const regex = /(?: 0(?=1|\b)| 1(?=2|\b)| 2(?=3|\b)| 3(?=4|\b)| 4(?=5|\b)| 5(?=6|\b)| 6(?=7|\b)| 7(?=8|\b)| 8(?=9|\b)| 9\b ){5}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?: 0(?=1|\\b)| 1(?=2|\\b)| 2(?=3|\\b)| 3(?=4|\\b)| 4(?=5|\\b)| 5(?=6|\\b)| 6(?=7|\\b)| 7(?=8|\\b)| 8(?=9|\\b)| 9\\b ){5}', 'g')
const str = `123 321 56789 890123 321098 134 333 421 12345 6789
15246
1234567890
67890
12345
23456
34567
456789
56789
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}