use strict;
my $str = '123 321 56789 890123 321098 134 333 421 12345 6789
15246
1234567890
67890
12345
23456
34567
456789
56789
';
my $regex = qr/(?: 0(?=1|\b)| 1(?=2|\b)| 2(?=3|\b)| 3(?=4|\b)| 4(?=5|\b)| 5(?=6|\b)| 6(?=7|\b)| 7(?=8|\b)| 8(?=9|\b)| 9\b ){5}/xp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}