using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:""[^""\s]*""[^""]*)*(""\S*\s[^""]*"")";
string input = @"adb shell am startservice -n fooApp/barService -a INVOKE --es ""key"" ""key1"" --es ""value"" ""value 2 has spaces""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}