import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\"[^\"\\s]*\"[^\"]*)*(\"\\S*\\s[^\"]*\")";
final String string = "adb shell am startservice -n fooApp/barService -a INVOKE --es \"key\" \"key1\" --es \"value\" \"value 2 has spaces\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}