const regex = /(?:"[^"\s]*"[^"]*)*("\S*\s[^"]*")/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:"[^"\\s]*"[^"]*)*("\\S*\\s[^"]*")', 'g')
const str = `adb shell am startservice -n fooApp/barService -a INVOKE --es "key" "key1" --es "value" "value 2 has spaces"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}