package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:"[^"\s]*"[^"]*)*("\S*\s[^"]*")`)
var str = `adb shell am startservice -n fooApp/barService -a INVOKE --es "key" "key1" --es "value" "value 2 has spaces"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}