re = /(?:"[^"\s]*"[^"]*)*("\S*\s[^"]*")/
str = 'adb shell am startservice -n fooApp/barService -a INVOKE --es "key" "key1" --es "value" "value 2 has spaces"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end