# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(one.*?)(one)(.*)/\1\(\2\)\3/gm;t' <<< "one two three one one
"