const regex = /(one.*?)(one)(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(one.*?)(one)(.*)', 'gm')
const str = `one two three one one
`;
const subst = `\1\(\2\)\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);