$re = '/(one.*?)(one)(.*)/m';
$str = 'one two three one one
';
$subst = "\1\(\2\)\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;