re = /(one.*?)(one)(.*)/m
str = 'one two three one one
'
subst = '\\1\\(\\2\\)\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result