#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(one.*?)(one)(.*)"
Local $sString = "one two three one one" & @CRLF & _
""
Local $sSubst = "\1\(\2\)\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)