import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.{67})[A-Za-z0-9.\\-–—_ÞÀÁÂÃÄÅÆàáâãäåæßÇç¢ÐÈÉÊËèéêëƒÌÍÎÏìíîïðÑñÒÓÔÕÖØŒòóôõöøœŠšÙÚÛÜùúûüµþŸÝÿýžŽ?'*/\\;=`+’!^<>\\[\\]]+@(([A-Za-z0-9\\-–—_ÞÀÁÂÃÄÅÆàáâãäåæßÇç¢ÐÈÉÊËèéêëƒÌÍÎÏìíîïðÑñÒÓÔÕÖØŒòóôõöøœŠšÙÚÛÜùúûüµþŸÝÿýžŽ?'*/\\;=`+’!^<>\\[\\]]+\\.[A-Za-z0-9.\\-–—_ÞÀÁÂÃÄÅÆàáâãäåæßÇç¢ÐÈÉÊËèéêëƒÌÍÎÏìíîïðÑñÒÓÔÕÖØŒòóôõöøœŠšÙÚÛÜùúûüµþŸÝÿýžŽ?'*/\\;=`+’!^<>\\[\\]]*[A-Za-z0-9ÞÀÁÂÃÄÅÆàáâãäåæßÇç¢ÐÈÉÊËèéêëƒÌÍÎÏìíîïðÑñÒÓÔÕÖØŒòóôõöøœŠšÙÚÛÜùúûüµþŸÝÿýžŽ?'*/\\;=`+’!^<>\\[\\]]{2,})|(\\[[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\]))$";
final String string = "simple@example.com\n"
+ "disposable.style.email.with+symbol@example.com\n"
+ "fully-qualified-domain@example.com\n"
+ "user.name+tag+sorting@example.com\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}