const regex = /^(?!.{67})[A-Za-z0-9.\-–—_ÞÀÁÂÃÄÅÆàáâãäåæßÇç¢ÐÈÉÊËèéêëƒÌÍÎÏìíîïðÑñÒÓÔÕÖØŒòóôõöøœŠšÙÚÛÜùúûüµþŸÝÿýžŽ?'*/\;=`+’!^<>\[\]]+@(([A-Za-z0-9\-–—_ÞÀÁÂÃÄÅÆàáâãäåæßÇç¢ÐÈÉÊËèéêëƒÌÍÎÏìíîïðÑñÒÓÔÕÖØŒòóôõöøœŠšÙÚÛÜùúûüµþŸÝÿýžŽ?'*/\;=`+’!^<>\[\]]+\.[A-Za-z0-9.\-–—_ÞÀÁÂÃÄÅÆàáâãäåæßÇç¢ÐÈÉÊËèéêëƒÌÍÎÏìíîïðÑñÒÓÔÕÖØŒòóôõöøœŠšÙÚÛÜùúûüµþŸÝÿýžŽ?'*/\;=`+’!^<>\[\]]*[A-Za-z0-9ÞÀÁÂÃÄÅÆàáâãäåæßÇç¢ÐÈÉÊËèéêëƒÌÍÎÏìíîïðÑñÒÓÔÕÖØŒòóôõöøœŠšÙÚÛÜùúûüµþŸÝÿýžŽ?'*/\;=`+’!^<>\[\]]{2,})|(\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\]))$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.{67})[A-Za-z0-9.\\-–—_ÞÀÁÂÃÄÅÆàáâãäåæßÇç¢ÐÈÉÊËèéêëƒÌÍÎÏìíîïðÑñÒÓÔÕÖØŒòóôõöøœŠšÙÚÛÜùúûüµþŸÝÿýžŽ?\'*\/\\;=`+’!^<>\\[\\]]+@(([A-Za-z0-9\\-–—_ÞÀÁÂÃÄÅÆàáâãäåæßÇç¢ÐÈÉÊËèéêëƒÌÍÎÏìíîïðÑñÒÓÔÕÖØŒòóôõöøœŠšÙÚÛÜùúûüµþŸÝÿýžŽ?\'*\/\\;=`+’!^<>\\[\\]]+\\.[A-Za-z0-9.\\-–—_ÞÀÁÂÃÄÅÆàáâãäåæßÇç¢ÐÈÉÊËèéêëƒÌÍÎÏìíîïðÑñÒÓÔÕÖØŒòóôõöøœŠšÙÚÛÜùúûüµþŸÝÿýžŽ?\'*\/\\;=`+’!^<>\\[\\]]*[A-Za-z0-9ÞÀÁÂÃÄÅÆàáâãäåæßÇç¢ÐÈÉÊËèéêëƒÌÍÎÏìíîïðÑñÒÓÔÕÖØŒòóôõöøœŠšÙÚÛÜùúûüµþŸÝÿýžŽ?\'*\/\\;=`+’!^<>\\[\\]]{2,})|(\\[[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\]))$', '')
const str = `simple@example.com
disposable.style.email.with+symbol@example.com
fully-qualified-domain@example.com
user.name+tag+sorting@example.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}