re = /^(?!.{67})[A-Za-z0-9.\-–—_ÞÀÁÂÃÄÅÆàáâãäåæßÇç¢ÐÈÉÊËèéêëƒÌÍÎÏìíîïðÑñÒÓÔÕÖØŒòóôõöøœŠšÙÚÛÜùúûüµþŸÝÿýžŽ?'*\/\;=`+’!^<>\[\]]+@(([A-Za-z0-9\-–—_ÞÀÁÂÃÄÅÆàáâãäåæßÇç¢ÐÈÉÊËèéêëƒÌÍÎÏìíîïðÑñÒÓÔÕÖØŒòóôõöøœŠšÙÚÛÜùúûüµþŸÝÿýžŽ?'*\/\;=`+’!^<>\[\]]+\.[A-Za-z0-9.\-–—_ÞÀÁÂÃÄÅÆàáâãäåæßÇç¢ÐÈÉÊËèéêëƒÌÍÎÏìíîïðÑñÒÓÔÕÖØŒòóôõöøœŠšÙÚÛÜùúûüµþŸÝÿýžŽ?'*\/\;=`+’!^<>\[\]]*[A-Za-z0-9ÞÀÁÂÃÄÅÆàáâãäåæßÇç¢ÐÈÉÊËèéêëƒÌÍÎÏìíîïðÑñÒÓÔÕÖØŒòóôõöøœŠšÙÚÛÜùúûüµþŸÝÿýžŽ?'*\/\;=`+’!^<>\[\]]{2,})|(\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\]))$/
str = 'simple@example.com
disposable.style.email.with+symbol@example.com
fully-qualified-domain@example.com
user.name+tag+sorting@example.com
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end