import Foundation
let pattern = #"^(?!.{67})[A-Za-z0-9.\-–—_ÞÀÁÂÃÄÅÆàáâãäåæßÇç¢ÐÈÉÊËèéêëƒÌÍÎÏìíîïðÑñÒÓÔÕÖØŒòóôõöøœŠšÙÚÛÜùúûüµþŸÝÿýžŽ?'*/\;=`+’!^<>\[\]]+@(([A-Za-z0-9\-–—_ÞÀÁÂÃÄÅÆàáâãäåæßÇç¢ÐÈÉÊËèéêëƒÌÍÎÏìíîïðÑñÒÓÔÕÖØŒòóôõöøœŠšÙÚÛÜùúûüµþŸÝÿýžŽ?'*/\;=`+’!^<>\[\]]+\.[A-Za-z0-9.\-–—_ÞÀÁÂÃÄÅÆàáâãäåæßÇç¢ÐÈÉÊËèéêëƒÌÍÎÏìíîïðÑñÒÓÔÕÖØŒòóôõöøœŠšÙÚÛÜùúûüµþŸÝÿýžŽ?'*/\;=`+’!^<>\[\]]*[A-Za-z0-9ÞÀÁÂÃÄÅÆàáâãäåæßÇç¢ÐÈÉÊËèéêëƒÌÍÎÏìíîïðÑñÒÓÔÕÖØŒòóôõöøœŠšÙÚÛÜùúûüµþŸÝÿýžŽ?'*/\;=`+’!^<>\[\]]{2,})|(\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\]))$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
simple@example.com
disposable.style.email.with+symbol@example.com
fully-qualified-domain@example.com
user.name+tag+sorting@example.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}